Uwaga! Od sierpnia 2017 forum jest w trybie tylko do odczytu.

Dlaczego? Dlatego, że społeczność TYPO3 przeniosła się na slack'a i stackoverflow:
  • Przeczytaj artykuł wprowadzający do slacka, w którym dowiesz gdzie i jak się zarejestrować.
  • Jeżeli masz pytania odnośnie Polskiej Społeczności TYPO3 zapraszamy na kanał slack'a #community-pl. Rozmawiamy tam w języku polskim.
  • Pytania dotyczące samego TYPO3 zadawaj po angielsku na stackoverflow oznaczając je tagiem "typo3". Następnie posługując się linkiem do tego pytania postaraj się zachęcić ludzi z kanału slack'a #typo3-cms lub bardziej pasujących kanałów tematycznych, żeby na nie odpowiedzieli.
  • Możesz też oczywiście zadawać pytania na slacku bez zakładania wątków na stackoverflow, ale wówczas wiedza ta nie jest indeksowana przez googla i część osób nie będzie chciała Ci z tego powodu pomagać.
  • Dla części osób dzielących się wiedzą ważne jest też budowanie reputacji na stackoverflow. Jest to kolejny powód dla którego powinieneś zadawać pytania na stackoverflow by zwiększyć swoje szanse na znalezienie odpowiedzi. Pamiętaj, żeby oceniać odpowiedzi!
Tematy bez nowych odpowiedzi

Katalog a domena


Autor Wiadomość
Napisane: 18.07.2011 [23:42]
zigzag
admin
Twórca tematu
zarejestrowany: 18.05.2010
Posty: 72
Witam mam taki problem.

Wykonałem instalację TYPO3 na serwerze home.pl korzystając z domeny mojadomena.home.pl/system/ (folder system w katalogu głównym)
Wszystko fajnie ale po przekierowaniu właściwej domeny na katalog:

1. Nie działa backend (brak obazków przy logowaniu, nic się nie wyświetla po zalogowaniu)
2. Starałem się skonfigurować po raz pierwszy Indexed Search Engine (indexed_search)
Kiedy otwieram stonę z dodanym pluginem indexed_search za pomocą domeny xxxx.home.pl wyświetla się wyszukiwarka kiedy otwieram jąza pomocą mojadomena.pl nie ma

Mam skonfigurowane RealUrl wraz z dodaną i działają bez problemów kiedy korzystam z domeny mojadomena.pl

Główny szablon TS
TYPOSCRIPT
config.simulateStaticDocuments = 0
config.baseURL = http://www.mojadomena.pl/
config.tx_realurl_enable = 1
config.typolinkEnableLinksAcrossDomains = 1


Szukałem na forum i na google ale jedyne co znajduje to (config.baseURL)

[Ten temat był edytowany 1 razy. Ostatnio 18.07.2011 o 23:44.]
Napisane: 19.07.2011 [00:45]
zigzag
admin
Twórca tematu
zarejestrowany: 18.05.2010
Posty: 72
Właśnie zauważyłem wchodząc w 'Info -> Indexed search' że strony nie są indeksowane do wyszukiwania nie odświeżywszy ich korzystając z domeny xxx.home.pl

Ratunku banghead.gif
Napisane: 22.07.2011 [10:34]
kss
zarejestrowany: 19.07.2007
Posty: 1341

Serwery home.pl mają ścieżkę bezwzględną postaci "/" jeżeli przekierujesz doemenę na katalog. Prowadzi to do błędnego działania wielu aplikacji w tym również TYPO3.

Żeby TYPO3 zaczął działać na home.pl trzeba wykonać poprawki w źródle wg następującego wątku.

http://forum.typo3.pl/forum/post/instalacja/1955.html?tx_mmforum_pi1[pid]=strona&tx_mmforum_pi1[sword]=home.pl#pid9118

=======================================
t33k
Napisane: 23.07.2011 [20:19]
zigzag
admin
Twórca tematu
zarejestrowany: 18.05.2010
Posty: 72
Dzięki!