Uwaga! Od sierpnia 2017 forum jest w trybie tylko do odczytu.

Dlaczego? Dlatego, że społeczność TYPO3 przeniosła się na slack'a i stackoverflow:
  • Przeczytaj artykuł wprowadzający do slacka, w którym dowiesz gdzie i jak się zarejestrować.
  • Jeżeli masz pytania odnośnie Polskiej Społeczności TYPO3 zapraszamy na kanał slack'a #community-pl. Rozmawiamy tam w języku polskim.
  • Pytania dotyczące samego TYPO3 zadawaj po angielsku na stackoverflow oznaczając je tagiem "typo3". Następnie posługując się linkiem do tego pytania postaraj się zachęcić ludzi z kanału slack'a #typo3-cms lub bardziej pasujących kanałów tematycznych, żeby na nie odpowiedzieli.
  • Możesz też oczywiście zadawać pytania na slacku bez zakładania wątków na stackoverflow, ale wówczas wiedza ta nie jest indeksowana przez googla i część osób nie będzie chciała Ci z tego powodu pomagać.
  • Dla części osób dzielących się wiedzą ważne jest też budowanie reputacji na stackoverflow. Jest to kolejny powód dla którego powinieneś zadawać pytania na stackoverflow by zwiększyć swoje szanse na znalezienie odpowiedzi. Pamiętaj, żeby oceniać odpowiedzi!
Tematy bez nowych odpowiedzi

tytuł strony na dwóch polach z bazy


Autor Wiadomość
Napisane: 06.04.2014 [10:38]
tomkraw1
admin
Twórca tematu
zarejestrowany: 14.07.2008
Posty: 530
Mam własne rozszerzenie, które imię i nazwisko przechowuje w osobnych polach bazy. Teraz w widoku singe view chcę dać tytuł strony + imię i nazwisko.

W taki sposób wyciągam samo nazwisko:
TYPOSCRIPT
[globalVar = TSFE:id = 3]
config.noPageTitle = 2
 
temp.teamTitle = RECORDS
temp.teamTitle {
	dontCheckPid = 1
	tables = tx_kbbteam_domain_model_members
	source.data = GP:tx_kbbteam_members|members
	source.intval = 1
	conf.tx_kbbteam_domain_model_members = TEXT
	conf.tx_kbbteam_domain_model_members {
		field = last_name
		htmlSpecialChars = 1
	}
	stdWrap.wrap = <title>{page:title} - |</title>
	stdWrap.insertData = 1
}
page.headerData.1 >
page.headerData.1 < temp.teamTitle
[global]


ale
TYPOSCRIPT
field = CONCAT(first_name, ' ', last_name)
nie działa

Jak to zrobić?

pozdrawiam
Tomek
Napisane: 07.04.2014 [21:24]
kss
zarejestrowany: 19.07.2007
Posty: 1341

A dlaczego nie nadajesz title z poziomu wtyczki?
Zobacz ext "news".

=======================================
t33k
Napisane: 12.06.2014 [12:08]
tomkraw1
admin
Twórca tematu
zarejestrowany: 14.07.2008
Posty: 530
Za radą Krystiana przekopiowałem TitleTagViewHelper.php, zmieniłem namespace na moje i dodałem we fluidowym szablonie oba moje pola. Działa.

pozdrawiam
Tomek