Uwaga! Od sierpnia 2017 forum jest w trybie tylko do odczytu.

Dlaczego? Dlatego, że społeczność TYPO3 przeniosła się na slack'a i stackoverflow:
  • Przeczytaj artykuł wprowadzający do slacka, w którym dowiesz gdzie i jak się zarejestrować.
  • Jeżeli masz pytania odnośnie Polskiej Społeczności TYPO3 zapraszamy na kanał slack'a #community-pl. Rozmawiamy tam w języku polskim.
  • Pytania dotyczące samego TYPO3 zadawaj po angielsku na stackoverflow oznaczając je tagiem "typo3". Następnie posługując się linkiem do tego pytania postaraj się zachęcić ludzi z kanału slack'a #typo3-cms lub bardziej pasujących kanałów tematycznych, żeby na nie odpowiedzieli.
  • Możesz też oczywiście zadawać pytania na slacku bez zakładania wątków na stackoverflow, ale wówczas wiedza ta nie jest indeksowana przez googla i część osób nie będzie chciała Ci z tego powodu pomagać.
  • Dla części osób dzielących się wiedzą ważne jest też budowanie reputacji na stackoverflow. Jest to kolejny powód dla którego powinieneś zadawać pytania na stackoverflow by zwiększyć swoje szanse na znalezienie odpowiedzi. Pamiętaj, żeby oceniać odpowiedzi!
Temat bez odpowiedzi

problem z menu


Autor Wiadomość
Napisane: 23.08.2012 [09:45]
strongBAD
zarejestrowany: 23.08.2012
Posty: 1
witam,

ostatnio przy przebudowie strony chciałem dodać do menu dodatkowy element, menu wygląda następująco:

+ page (uid: 551 )
- subpage (uid: 6 )
- subpage (uid: 198 )
- subpage (uid: 349 )
+ page (uid: 552)
- subpage (uid: 556 )
- subpage (uid: 557 )
+ page (uid: 795)
- subpage (uid: 860 )

Nie wiem dlaczego, ale ostatni element menu page (uid: 795) nie wyświetla się, co robię źle? Oto mój ts:

TYPOSCRIPT
###
### Products
###
 
# Page Navigation
 
lib.topnav.products.typeNav = HMENU
lib.topnav.products.typeNav {
    special = list
    special.value = 551, 552, 795
 
    1 = TMENU
    1 {
        wrap = <ul id="topnav-content-products-typeNav"> | </ul><div style="clear:both;"></div>
        noBlur = 1
 
        IProcFunc = user_IProcFuncTopNavProductsTypeNav
 
        NO.allWrap = <li> | </li>
 
        ACT < .NO
        ACT = 1
        ACT.ATagParams = class="active defaultActive"
    }
}
 
 
# Subpage navigation
 
lib.topnav.products.productlineNav.system = HMENU
lib.topnav.products.productlineNav.system {
    special = list
    special.value = 6, 198, 349
 
    1 = TMENU
    1 {
        wrap = <ul class="topnav-content-products-productlineNav"> | </ul><div style="clear:both;"></div>
        noBlur = 1 
 
        IProcFunc = user_IProcFuncTopNavProductsProductlineNav
 
        NO.allWrap = <li> | </li>
 
        ACT < .NO
        ACT = 1
        ACT.ATagParams = class="active defaultActive"
    }
}
 
# separate ul 
 
lib.topnav.products.productlineNav.spots < lib.topnav.products.productlineNav.system
lib.topnav.products.productlineNav.spots.special.value = 557, 556
 
# separate ul 
 
lib.topnav.products.productlineNav.io < lib.topnav.products.productlineNav.spots
lib.topnav.products.productlineNav.io.special.value = 860


nie używam Templavoila, czy element lib.topnav.products.productlineNav.io muszę gdzieś dodatkowo rejestrować?

z góry dzięki za pomoc,
pozdrawiam