Uwaga! Od sierpnia 2017 forum jest w trybie tylko do odczytu.

Dlaczego? Dlatego, że społeczność TYPO3 przeniosła się na slack'a i stackoverflow:
  • Przeczytaj artykuł wprowadzający do slacka, w którym dowiesz gdzie i jak się zarejestrować.
  • Jeżeli masz pytania odnośnie Polskiej Społeczności TYPO3 zapraszamy na kanał slack'a #community-pl. Rozmawiamy tam w języku polskim.
  • Pytania dotyczące samego TYPO3 zadawaj po angielsku na stackoverflow oznaczając je tagiem "typo3". Następnie posługując się linkiem do tego pytania postaraj się zachęcić ludzi z kanału slack'a #typo3-cms lub bardziej pasujących kanałów tematycznych, żeby na nie odpowiedzieli.
  • Możesz też oczywiście zadawać pytania na slacku bez zakładania wątków na stackoverflow, ale wówczas wiedza ta nie jest indeksowana przez googla i część osób nie będzie chciała Ci z tego powodu pomagać.
  • Dla części osób dzielących się wiedzą ważne jest też budowanie reputacji na stackoverflow. Jest to kolejny powód dla którego powinieneś zadawać pytania na stackoverflow by zwiększyć swoje szanse na znalezienie odpowiedzi. Pamiętaj, żeby oceniać odpowiedzi!
Tematy bez nowych odpowiedzi

Problem Real URL


Autor Wiadomość
Napisane: 17.06.2012 [20:33]
Pablo
Twórca tematu
zarejestrowany: 19.01.2012
Posty: 7
Witam,

Mam kolejny problem z tym rozszerzeniem icon_frown.gif Jakiś czas temu miałem to samo ale mi się udało go naprawić. Niestety nie pamiętam jak icon_frown.gif
Chodzi o to że zainstalowałem to rozszerzenie i wszystko działało super. Niestety problem polegał na tym że strona ma kilka wersji językowe i klientowi się nie spodobało to że jak przełącze język to się pokazywało www.page.com/?lang=en dla język angielski dla francuski to fr itd. Więc wszedłem do Extension Manager/RealUrl/Settings i wyłączyłem "Enable automatic configuration" i stworzyłem plik "typo3conf/realurl_conf.php". Dodałem kod z instrukcji
PHP
'preVars' => array(
   2:         array(
   3:             'GETvar' => 'no_cache',
   4:             'valueMap' => array(
   5:                 'no_cache' => 1,
   6:             ),
   7:             'noMatch' => 'bypass',
   8:         ),
   9:         array(
  10:             'GETvar' => 'L',
  11:             'valueMap' => array(
  12:                 'dk' => '1',
  13:                 'danish' => '1',
  14:                 'uk' => '2',
  15:                 'english' => '2',
  16:             ),
  17:             'noMatch' => 'bypass',
  18:         ),
  19:     ),


Niestety nie dość że dalej się wyświetla to glupie ?lang=* to zamiast ładny url(www.page.com/kontakt) to mam www.page.com/5 i tak dla każdej stronie mi się wyświetla tylko id strony. Usunałem ten plik: "realurl_conf.php" włączyłem "Enable automatic configuration". Ale niestety bez zmian dalej się wyświetla tylko id strony icon_frown.gif Na szczęści miałem RealURl wersji1.12.0 więć zrobiłem aktualizacje do 1.12.1 ale to nic mi nie dało. Czy któś miał taki problem i mógłby mi powiedzieć jak mogę to naprawić automatycznie? I ewentualnie jak zrobić te języki?
Znam jeden sposób Page>Edit>Behaviour a następnie nadaje nazwe "URL Alias" Niestety mam po nad 100 stroń i tak średnio mi się chce to wprowadzać nazwy icon_frown.gif
Napisane: 17.06.2012 [21:24]
mushroomhead
zarejestrowany: 25.11.2009
Posty: 51
nie jestem ekspertem od realurl, mnie to zawsze działało z marszu. Tyle, ze nie pamietam czy uzywałem tego w stronach wielojęzycznych. Ale jesli chodzi o wielojęzyczne, to szczerze polecam cooluri. Działa bez problemów i stworzy www.page.com/kontakt , www.page.com/en/contact , www.page.com/fr/contact itd itp
Wiec jak nie masz czasu na szukanie przyczyny, odinstalowałbym realurl i zainstalował cooluri.
Napisane: 18.06.2012 [14:25]
Pablo
Twórca tematu
zarejestrowany: 19.01.2012
Posty: 7
"mushroomhead" napisał/a

nie jestem ekspertem od realurl, mnie to zawsze działało z marszu. Tyle, ze nie pamietam czy uzywałem tego w stronach wielojęzycznych. Ale jesli chodzi o wielojęzyczne, to szczerze polecam cooluri. Działa bez problemów i stworzy www.page.com/kontakt , www.page.com/en/contact , www.page.com/fr/contact itd itp
Wiec jak nie masz czasu na szukanie przyczyny, odinstalowałbym realurl i zainstalował cooluri.


Hej, dzięki za odpowiedż.
Usunałem realurl i zainstalowałem cooluri. Na szczęścię już działaja url ale niestety pozostaje problem z językami icon_frown.gif
Napisane: 18.06.2012 [18:45]
mushroomhead
zarejestrowany: 25.11.2009
Posty: 51
A na czym polega ten problem z jezykami? Daj jakis przykład. (Sorry, lekko sie pogubiłem...)
Napisane: 21.06.2012 [20:32]
tomkraw1
admin
zarejestrowany: 14.07.2008
Posty: 530
Pablo RealUrl dobrze skonfigurowany po prostu działa.
RealUrl ma swój własny cache i zchche-uje nawet strony wygenerowane z błędną konfigurachą. To cache trzeba czyścić po każdej zmianie w realurl_conf.php. Poczytaj o ext: realurl_clearcache albo działaj w module Info.

Problem z www.domena.pl/1123 miewałem w przypadku błędów w .htaccess.

Pokaż Twój .htaccess oraz realurl_conf.php.

pozdrawiam
Tomek