Uwaga! Od sierpnia 2017 forum jest w trybie tylko do odczytu.

Dlaczego? Dlatego, że społeczność TYPO3 przeniosła się na slack'a i stackoverflow:
  • Przeczytaj artykuł wprowadzający do slacka, w którym dowiesz gdzie i jak się zarejestrować.
  • Jeżeli masz pytania odnośnie Polskiej Społeczności TYPO3 zapraszamy na kanał slack'a #community-pl. Rozmawiamy tam w języku polskim.
  • Pytania dotyczące samego TYPO3 zadawaj po angielsku na stackoverflow oznaczając je tagiem "typo3". Następnie posługując się linkiem do tego pytania postaraj się zachęcić ludzi z kanału slack'a #typo3-cms lub bardziej pasujących kanałów tematycznych, żeby na nie odpowiedzieli.
  • Możesz też oczywiście zadawać pytania na slacku bez zakładania wątków na stackoverflow, ale wówczas wiedza ta nie jest indeksowana przez googla i część osób nie będzie chciała Ci z tego powodu pomagać.
  • Dla części osób dzielących się wiedzą ważne jest też budowanie reputacji na stackoverflow. Jest to kolejny powód dla którego powinieneś zadawać pytania na stackoverflow by zwiększyć swoje szanse na znalezienie odpowiedzi. Pamiętaj, żeby oceniać odpowiedzi!
Tematy bez nowych odpowiedzi

filelist - brak polskich znaków


Autor Wiadomość
Napisane: 03.11.2011 [08:03]
wabik
Twórca tematu
zarejestrowany: 03.11.2011
Posty: 4
Witam,

Czy ktoś mi pomoże ... na razie jestem zielony i zapoznaję się z systemem.

Próbuję wylistować zawartość katalogu i to się udaje ... ale niestety jeśli plik zawiera polskie znaki w nazwie pojawiają się krzaki i nie chce otworzyć pliku icon_frown.gif

Kodowanie mam ustawione na UTF-8 ...

Dzięki za pomoc!

Pozdr.
wabik
Napisane: 03.11.2011 [22:20]
tomkraw1
admin
zarejestrowany: 14.07.2008
Posty: 530
Kodowanie bazy, systemu plików czy wyjściowej strony? Jaki OS?

pozdrawiam
Tomek
Napisane: 04.11.2011 [07:57]
wabik
Twórca tematu
zarejestrowany: 03.11.2011
Posty: 4
Witam,

Kurcze jakoś średnio się jeszcze orientuję w sofcie.
Zainstalowałem TYPO3 4.6.0 na Windowsie XP aby przetestować ... I chciałbym w panelu administracyjnym wylistować dla danego użytkownika jakieś katalogi (dla każdego inne). A tu niespodzianka ... katalogi się listują ale pliki z polskimi znakami nie chcą się otwierać icon_frown.gif

Pozdr.
wabik

[Ten temat był edytowany 1 razy. Ostatnio 04.11.2011 o 07:58.]
Napisane: 08.11.2011 [13:16]
tomkraw1
admin
zarejestrowany: 14.07.2008
Posty: 530
Na Windows lepiej unikać plików z polskimi znakami. Na Unixach i Linuxach też tego unikam.

W serwisie, który uruchamiałem na IIS XClassowałem klasę do operacji na plikach by niepokorni użytkownicy nie mogli tworzyć katalogów oraz uploadować plików z polskimi znaczkami.

pozdrawiam
Tomek
Napisane: 08.11.2011 [13:18]
wabik
Twórca tematu
zarejestrowany: 03.11.2011
Posty: 4
Wszystko się zgadza ale ja musze dostosować system do istniejących warunków ... a te wymagają polskich liter icon_frown.gif