Uwaga! Od sierpnia 2017 forum jest w trybie tylko do odczytu.

Dlaczego? Dlatego, że społeczność TYPO3 przeniosła się na slack'a i stackoverflow:
  • Przeczytaj artykuł wprowadzający do slacka, w którym dowiesz gdzie i jak się zarejestrować.
  • Jeżeli masz pytania odnośnie Polskiej Społeczności TYPO3 zapraszamy na kanał slack'a #community-pl. Rozmawiamy tam w języku polskim.
  • Pytania dotyczące samego TYPO3 zadawaj po angielsku na stackoverflow oznaczając je tagiem "typo3". Następnie posługując się linkiem do tego pytania postaraj się zachęcić ludzi z kanału slack'a #typo3-cms lub bardziej pasujących kanałów tematycznych, żeby na nie odpowiedzieli.
  • Możesz też oczywiście zadawać pytania na slacku bez zakładania wątków na stackoverflow, ale wówczas wiedza ta nie jest indeksowana przez googla i część osób nie będzie chciała Ci z tego powodu pomagać.
  • Dla części osób dzielących się wiedzą ważne jest też budowanie reputacji na stackoverflow. Jest to kolejny powód dla którego powinieneś zadawać pytania na stackoverflow by zwiększyć swoje szanse na znalezienie odpowiedzi. Pamiętaj, żeby oceniać odpowiedzi!
Forum » TYPO3 » Ogólne
Tematy bez nowych odpowiedzi

Brak skalowania obrazów


Autor Wiadomość
Napisane: 22.06.2015 [00:55]
Imp
Twórca tematu
zarejestrowany: 13.04.2011
Posty: 170
Witam,

Zauważyłem problem ze skalowaniem obrazów. Wersja TYPO3 6.2.12, po aktualizacji do 6.2.13 nadal bez zmian.

Wszystkie obrazy wstawiane popszez content images+text lub images są renderowane na stronie w swojej oryginalnej rozdzielczości, do tego nie są to obrazki przetrawione przez IM tylko oryginały wysłane na serwer i zapisywane w user-upload/..

Z obrazkami w FCE z TemplaVoila jest ciekawiej - w podstawowej wersji językowej obrazki są przetrawione przez IM i są skalowane - źródła obrazów wskazują na typo3temp/_processed_/.. natomiast w języku innym niż domyślny, w przetłumaczonych elementach obrazy nie są skalowane i nieprzetworzone.


Czy to jest wina ImageMagic'a? czy przeoczyłem coś w konfiguracji? Sporo szukałem, czyściłem wszystkie możliwe cache i pliki poprzez InstallTool i stanąłem w miejscu.



Pozdrawiam

[Ten temat był edytowany 1 razy. Ostatnio 22.06.2015 o 00:55.]
Napisane: 14.07.2015 [00:58]
Imp
Twórca tematu
zarejestrowany: 13.04.2011
Posty: 170
Konfiguracja RealURL jest następująca:

PHP
<?php
 
$TYPO3_CONF_VARS['EXTCONF']['realurl'] = array(
	'www.domena.pl' =>  array(
		'init' => array(
			'enableCHashCache' => true,
			'appendMissingSlash' => 'ifNotFile,redirect',
			'adminJumpToBackend' => true,
			'enableUrlDecodeCache' => true,
			'enableUrlEncodeCache' => true,
			'emptyUrlReturnValue' => '/',
//   			'postVarSet_failureMode'=>'redirect_goodUpperDir', //
		),
 
		'redirects' => array(),
 
		'preVars' => array(
			0 => array(
				'GETvar' => 'L',
				'valueMap' => array(
					'pl' => '0',
					'en' => '1',
				),
				'noMatch' => 'bypass',
			),
		),
 
		'pagePath' => array(
			'type' => 'user',
			'userFunc' => 'EXT:realurl/class.tx_realurl_advanced.php:&tx_realurl_advanced->main',
			'spaceCharacter' => '-',
			'languageGetVar' => 'L',
			'rootpage_id' => '1',
		),
 
		'fixedPostVars' => array(), //
 
		'postVarSets' => array(
			'_DEFAULT' => array(
				'archive' => array(
					'0' => array(
						'GETvar' => 'tx_ttnews[year]',
					),
					'1' => array(
						'GETvar' => 'tx_ttnews[month]',
						'valueMap' => array(
							'january' => '01',
							'february' => '02',
							'march' => '03',
							'april' => '04',
							'may' => '05',
							'june' => '06',
							'july' => '07',
							'august' => '08',
							'september' => '09',
							'october' => '10',
							'november' => '11',
							'december' => '12',
						),
					),
				),
				'browse' => array(
					'0' => array(
						'GETvar' => 'tx_ttnews[pointer]',
					),
				),
				'by' => array(
					'0' => array(
						'GETvar' => 'tx_ttnews[cat]',
						'lookUpTable' => array( //
							'table' => 'tt_news_cat',
							'id_field' => 'uid',
							'alias_field' => 'title',
							'addWhereClause' => ' AND NOT deleted',
							'useUniqueCache' => 1,
							'useUniqueCache_conf' => array(
								'strtolower' => 1,
								'spaceCharacter' => '-',
							),
						),
					),
				),
				'article' => array(
					'0' => array(
						'GETvar' => 'tx_ttnews[tt_news]',
						'lookUpTable' => array(
							'table' => 'tt_news',
							'id_field' => 'uid',
							'alias_field' => 'title',
							'addWhereClause' => ' AND NOT deleted',
							'useUniqueCache' => '1',
							'useUniqueCache_conf' => array(
								'strtolower' => '1',
								'spaceCharacter' => '-',
							),
						),
					),
					'1' => array(
						'GETvar' => 'tx_ttnews[backPid]',
					),
				),
				'results' => array(
					'0' => array(
					 'GETvar' => 'tx_ttnews[swords]',
					),
				),
			),
		),
 
		'fileName' => array(
			'defaultToHTMLsuffixOnPrev' => 0,
			'acceptHTMLsuffix' => true,
 
			'index' => array(
				'rss.xml' => array(
					'keyValues' => array(
						'type' => 100,
					),
				),
				'rss091.xml' => array(
					'keyValues' => array(
						'type' => 101,
					),
				),
				'rdf.xml' => array(
					'keyValues' => array(
						'type' => 102,
					),
				),
				'atom.xml' => array(
					'keyValues' => array(
						'type' => 103,
					),
				),
			),
		),
 
	),
 
);
 
$TYPO3_CONF_VARS['EXTCONF']['realurl']['www.domena.com'] = $TYPO3_CONF_VARS['EXTCONF']['realurl']['www.domena.pl'];
 
$TYPO3_CONF_VARS['EXTCONF']['realurl']['_DOMAINS'] = array(
	'encode' => array(
		array(
			'GETvar' => 'L',
			'value' => '',
			'ifDifferentToCurrent' => TRUE,
			'useConfiguration' => 'www.domena.pl',
			'urlPrepend' => 'http://www.domena.pl',
		),
		array(
			'GETvar' => 'L',
			'value' => '0',
			'ifDifferentToCurrent' => TRUE,
			'useConfiguration' => 'www.domena.pl',
			'urlPrepend' => 'http://www.domena.pl',
		),
		array(
			'GETvar' => 'L',
			'value' => '1',
			'ifDifferentToCurrent' => TRUE,
			'useConfiguration' => 'www.domena.com',
			'urlPrepend' => 'http://www.domena.com',
		),
	),
	'decode' => array(
		'www.nanoformula.pl' => array(
			'GETvars' => array(
				'L' => '0',
			),
			'useConfiguration' => 'www.domena.pl',
		),
		'www.nanoceramicprotect.com' => array(
			'GETvars' => array(
				'L' => '1',
			),
			'useConfiguration' => 'www.domena.com',
		),
	),
);
 
?>


W skrócie - język polski domena .pl, język angielski domena .com

W typoscript w setup zmieniam baseURL dla języka alternatywnego.



W języku polskim wszystkie obrazki na stronie są ładowane z typo3temp/_processed_/

W języku angielskim wszystkie obrazki sę ładowane z uploads/tx_templavoila/ w przypadku FCE lub z fileadmin/user-upload/ w przypadku zwykłego content - ładowane są obrazy źródłowe kopiowane na serwer.

Przy konfiguracji automatycznej realURL jest tak samo.


nie mam pojęcia co z tym zrobić.


Pozdrawiam.