Uwaga! Od sierpnia 2017 forum jest w trybie tylko do odczytu.

Dlaczego? Dlatego, że społeczność TYPO3 przeniosła się na slack'a i stackoverflow:
  • Przeczytaj artykuł wprowadzający do slacka, w którym dowiesz gdzie i jak się zarejestrować.
  • Jeżeli masz pytania odnośnie Polskiej Społeczności TYPO3 zapraszamy na kanał slack'a #community-pl. Rozmawiamy tam w języku polskim.
  • Pytania dotyczące samego TYPO3 zadawaj po angielsku na stackoverflow oznaczając je tagiem "typo3". Następnie posługując się linkiem do tego pytania postaraj się zachęcić ludzi z kanału slack'a #typo3-cms lub bardziej pasujących kanałów tematycznych, żeby na nie odpowiedzieli.
  • Możesz też oczywiście zadawać pytania na slacku bez zakładania wątków na stackoverflow, ale wówczas wiedza ta nie jest indeksowana przez googla i część osób nie będzie chciała Ci z tego powodu pomagać.
  • Dla części osób dzielących się wiedzą ważne jest też budowanie reputacji na stackoverflow. Jest to kolejny powód dla którego powinieneś zadawać pytania na stackoverflow by zwiększyć swoje szanse na znalezienie odpowiedzi. Pamiętaj, żeby oceniać odpowiedzi!
Temat bez odpowiedzi

File Upload - problem ze ścieżką docelową


Autor Wiadomość
Napisane: 11.12.2013 [18:22]
brivek
zarejestrowany: 19.04.2013
Posty: 3
Witam,

mam problem z wtyczką File Upload (1.1.0). Jako ścieżkę docelową mam podane: fileupload/xxx/yyy, jednak wszystkie pliki trafiają do fileupload.

TYPOSCRIPT
plugin.tx_fileupload_pi1.checkMime = 0
plugin.tx_fileupload_pi1.mimeInclude = *
plugin.tx_fileupload_pi1.mimeExclude =
plugin.tx_fileupload_pi1.checkExt = 1
plugin.tx_fileupload_pi1.extExclude = exe,php,php3
plugin.tx_fileupload_pi1.extInclude = *
plugin.tx_fileupload_pi1.FEuserHomePath = 0
plugin.tx_fileupload_pi1.maxsize = 315000000
plugin.tx_fileupload_pi1.path = /fileadmin/xxx/yyy/
plugin.tx_fileupload_pi1.noOverwrite = 1
plugin.tx_fileupload_pi1.fileMode = 0755
 
plugin.tx_fileupload_pi1.uploadformcObject = TEXT
plugin.tx_fileupload_pi1.uploadformcObject.value(
 
  ###STATUS###
  <form enctype="multipart/form-data" method="POST">
  <input type="hidden" name="MAX_FILE_SIZE" value="315000000">
  <input id="a" name="tx_fileupload_pi1" type="file"><br>
  <input id="b" type="submit" name="tx_fileupload_pi1[do_upload]" value="Wyślij">
  </form>
)


Próbowałem przed fileadmin nie stawiać /, ale wtedy w ogóle nie działa. Przeszukałem google, ale wszystkie wątki z tym problemem są bez odpowiedzi.

Z góry dziękuję za wszelką pomoc!

[Ten temat był edytowany 1 razy. Ostatnio 11.12.2013 o 18:23.]