Uwaga! Od sierpnia 2017 forum jest w trybie tylko do odczytu.

Dlaczego? Dlatego, że społeczność TYPO3 przeniosła się na slack'a i stackoverflow:
  • Przeczytaj artykuł wprowadzający do slacka, w którym dowiesz gdzie i jak się zarejestrować.
  • Jeżeli masz pytania odnośnie Polskiej Społeczności TYPO3 zapraszamy na kanał slack'a #community-pl. Rozmawiamy tam w języku polskim.
  • Pytania dotyczące samego TYPO3 zadawaj po angielsku na stackoverflow oznaczając je tagiem "typo3". Następnie posługując się linkiem do tego pytania postaraj się zachęcić ludzi z kanału slack'a #typo3-cms lub bardziej pasujących kanałów tematycznych, żeby na nie odpowiedzieli.
  • Możesz też oczywiście zadawać pytania na slacku bez zakładania wątków na stackoverflow, ale wówczas wiedza ta nie jest indeksowana przez googla i część osób nie będzie chciała Ci z tego powodu pomagać.
  • Dla części osób dzielących się wiedzą ważne jest też budowanie reputacji na stackoverflow. Jest to kolejny powód dla którego powinieneś zadawać pytania na stackoverflow by zwiększyć swoje szanse na znalezienie odpowiedzi. Pamiętaj, żeby oceniać odpowiedzi!
Forum » TYPO3 » Menu
Tematy bez nowych odpowiedzi

Menu z kontentem


Autor Wiadomość
Napisane: 14.02.2012 [11:25]
zbycho
Twórca tematu
zarejestrowany: 06.11.2009
Posty: 90
Witam po dłuższej przerwie...
Próbuję zbudować takie osobliwe menu, w którym zamiast standardowych wartości takich jak tytuł, subtytuł itd. będzie wyświetlany kontent z podstron.

mój ts wygląda następująco:
TYPOSCRIPT
temp.NAVI_LEVEL3BOX = HMENU
temp.NAVI_LEVEL3BOX {
  entryLevel = 3
 
  1 = TMENU
  1 {
    noBlur = 1
    NO = 1
    NO {
      stdWrap.cObject = COA
      stdWrap.cObject {
        10 = CONTENT
        10 {
          table = tt_content
          select{
             pidInList = pid
             languageField=sys_language_uid
             selectFields= header,text
             where = colPos=7
          }
        }
      }
    }
  }
}


i teraz tak. Na każdej z podstron mam zarezerwowaną jedną kolumnę (colPos=7). I to co tam jest chcę wyświetlić w menu. Ma ktoś jakiś pomysł jak tego dokonać?
Napisane: 14.02.2012 [12:40]
zbycho
Twórca tematu
zarejestrowany: 06.11.2009
Posty: 90
Znalazłem
zamiast
TYPOSCRIPT
pidInList = uid

powinno być
TYPOSCRIPT
pidInList.field = uid

Nie będę kasować wpisu bo może się komuś przydać